Project

General

Profile

Making it clear that libssl1.0-dev is needed

Added by Jason XiangJun about 1 year ago

Building of gdp_router_click depends on Openssl. If we just install the dependency using sudo apt install libssl-dev, libraries for OpenSSL 1.1.x will be installed but the source code is incompatible with the latest version. Instead, one should do sudo apt install libssl1.0-dev. This could be made clear in the README.md.


Replies (4)

RE: Making it clear that libssl1.0-dev is needed - Added by Eric Allman 12 months ago

What version of Linux are you running? On my Ubuntu 16.04 machine the default libssl is 1.0. But my first choice would be to rev the code so that it runs on the latest release, rather than relying on obsolete libraries.

RE: Making it clear that libssl1.0-dev is needed - Added by Jason XiangJun 12 months ago

I am running Ubuntu 18.0. Maybe that's why I have to explicitly install libssl1.0-dev.

RE: Making it clear that libssl1.0-dev is needed - Added by Eric Allman 12 months ago

Thanks. That's officially unsupported, but progress is a good thing, and I'll try to fix the problem. In the meantime it's my impression that you have worked around the problem. If you're really stuck please let me know and I'll bump this up to a higher priority.

RE: Making it clear that libssl1.0-dev is needed - Added by Eric Allman 12 months ago

It turns out that openssl1.1.1 disabled heartbeats, probably as a response to the Heartbleed problem, and gdp_router_click needs that feature. Oddly, the documentation says that Heartbleed was fixed in 1.0.1g, and so is presumably also fixed in 1.1.1. Even odder, it appears that heartbeats are enabled in the openssl 1.1.1 command line program, just not in the library. Very confusing, but it's going to be harder to fix than I had hoped. In the meantime I'll update the documentation as you suggest (and probably update adm/gdp-setup.sh to auto-install the right version.

    (1-4/4)