Project

General

Profile

Bug #100

gdp_gcl_read: ERROR: 404 not found [Berkeley:Swarm-GDP:404]

Added by Anonymous about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
05/09/2017
Due date:
% Done:

0%


Description

Locally, the gdp tests run for me, but when I run a Ptolemy module under Darwin or RHEL, I get an error.

See
http://terra.eecs.berkeley.edu:8080/job/ptII/1013/testReport/ptolemy.util.test.junit/AutoTests/_0___home_jenkins_workspace_ptII_ptolemy_actor_lib_jjs_modules_gdp_test_auto_GDPLogCreateAppendReadJS_xml__RunModel_/

Locally, I can reproduce this with

$PTII/bin/vergil $PTII/ptolemy/actor/lib/jjs/modules/gdp/test/auto/GDPLogCreateAppendReadJS.xml

The key part of the error message seems to be

_gdp_req_dispatch <<< NAK_C_NOTFOUND [gcl->refcnt 5]
    ERROR: 404 not found [Berkeley:Swarm-GDP:404]
<<< _gdp_invoke(0x7fa1065c0fc0 rid=0) CMD_READ: ERROR: 404 not found [Berkeley:Swarm-GDP:404]
<<< gdp_gcl_read: ERROR: 404 not found [Berkeley:Swarm-GDP:404]

See the attached log file for the complete output.

To install Ptolemy II, see https://www.icyphy.org/accessors/wiki/Main/PtolemyII

gdpLog.txt Magnifier (6.41 KB) Anonymous, 05/09/2017 06:09 AM

History

#1 Updated by Eric Allman about 5 years ago

  • Status changed from New to Feedback
  • Assignee set to Eric Allman

This doesn't look like a bug to me. The log you are trying to read, -M437wfuykwQ2KLSLb6OmOQYOpziuHkePrQJKnzgIUI, is empty, so when you try to read record 1 it correctly responds "not found". Am I missing something?

#2 Updated by Anonymous about 5 years ago

Interesting. It used to work, and now it does not. I'll roll back the ptII and accessors repo to when it passed and see if that makes a difference.

#3 Updated by Anonymous about 5 years ago

  • Status changed from Feedback to Closed

My bad. Thanks for looking into this, it prompted me to do a more thorough analysis. Basically, I updated an actor and changed a parameter name from interval to delay. In the process of doing that, I removed the values for the interval parameter for some other actors. This caused problems.

Thanks again for looking into this. I'll be more careful next time.

Also available in: Atom PDF