Project

General

Profile

Bug #111

gdplogd sends subscription events after a client sends CLOSE

Added by Nitesh Mor over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
gdplogd
Start date:
06/21/2017
Due date:
% Done:

0%


Description

When a client explicitly calls the gdp_gcl_close(...) on a gcl with active subscriptions, gdplogd still keeps sending new events as if the subscription was still active. The client behavior is correct in that it discards the incoming PDUs when there is no known GCL. To reproduce, run a patched gdp-reader that explicitly calls gdp_gcl_close(...) with a non-finished subscription. (patch attached).

See attached log-files from gdplogd and a subscriber client that receives such events. There are two clients connected to gdplogd during the given execution: one actively appending and the other with a subscription.

subclient.log Magnifier (3.61 KB) Nitesh Mor, 06/21/2017 11:25 PM

sub-gdplogd.log Magnifier - Log file for gdplogd with two clients (48.8 KB) Nitesh Mor, 06/21/2017 11:25 PM

gdp-reader.patch Magnifier (577 Bytes) Nitesh Mor, 06/21/2017 11:25 PM

subclient.log Magnifier - Subscription output with updated patch (3.84 KB) Nitesh Mor, 06/22/2017 01:28 PM

gdp-reader.patch Magnifier - Correct patch for gdp-reader (858 Bytes) Nitesh Mor, 06/22/2017 01:28 PM

History

#1 Updated by Eric Allman over 2 years ago

  • Status changed from New to In Progress

Are you sure that's the correct patch (gdp-reader.patch)? It is identical to the one you gave me for Bug #110, and since gdp-reader terminates immediately after the close it never gets a chance to read additional results. I added a five second delay which seems to be showing at least some problem, but I was wondering if you had anything more clever.

#2 Updated by Nitesh Mor over 2 years ago

You are correct. I am attaching a new patch and the client side output.

#3 Updated by Eric Allman over 2 years ago

  • Status changed from In Progress to Resolved

This should be fixed in commit:6414f1e7. Please test and close if working.

#4 Updated by Nitesh Mor over 2 years ago

  • Status changed from Resolved to Closed

Works. Thanks.

Also available in: Atom PDF