Project

General

Profile

Bug #137

Turning off ZeroConf will cause make to fail

Added by Jason XiangJun 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Start date:
11/30/2019
Due date:
% Done:

0%


Description

If ZeroConf were to be turned off by setting # define GDP_OSCF_USE_ZEROCONF to 0 in gdp_zc_client.h, build will fail.

Git Hash:
dd3b5025083c41c87cc8ebd65f5a939d30ab72da

Environment:
Linux ubuntu-vm 4.15.0-70-generic #79-Ubuntu SMP Tue Nov 12 10:36:11 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Expected behavior:
Build should be successful without ZEROCONF.

How to reproduce:
Change # define GDP_OSCF_USE_ZEROCONF to 0 and run make in the root directory.

History

#1 Updated by Eric Allman 7 months ago

  • Status changed from New to Resolved
  • Assignee set to Eric Allman

It turns out that someone had set things up so you had use "make all_noavahi" for this to work. I've fixed this in 2.2.1 so it should work as intended.

Also available in: Atom PDF