Project

General

Profile

Bug #28

gdplogd losing connection to the router. signature write failure: Success

Added by Nitesh Mor almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
07/28/2016
Due date:
08/15/2016
% Done:

0%


Description

The relevant error message in the logs (running at *=20)

*** Processing command 70=CMD_READ from socket 10
_gdp_req_dispatch >>> CMD_READ (70) [gcl->refcnt 1]
disk_read(1): EOF
_gdp_req_dispatch <<< CMD_READ
    ERROR: 404 not found [Berkeley:Swarm-GDP:404]
_gdp_pdu_out, fd = 10, basemd = (nil): NAK_C_NOTFOUND
_gdp_pdu_out: signature write failure: Success
_gdp_event_cb: got EOF, 0 bytes left
Re-using channel @ 0x1428290
     process = 0x411287
     advertise = 0x40613b
Trying Zeroconf:

Followed by this, the log-server just starts looking for zeroconf. I am not sure if the 'signature write failure: Success' message is related to the lost connection, or if it is a separate issue. See attached log for one full run of gdplogd.

gdplogd.log Magnifier - Log from gdplogd for a full run (at *=20) (19.3 KB) Nitesh Mor, 07/28/2016 05:07 PM


Related issues

Related to GDP - Bug #9: Router terminating connections abruptly Closed 07/02/2016
Related to GDP - Bug #30: Zeroconf lookup hangs on reconnect attempt Closed 08/02/2016

History

#1 Updated by Eric Allman almost 4 years ago

Just a hunch, but I wonder if this might be related to Issue #9 (Router terminating connections abruptly). I say this because the EOF indicates that the connection was closed. If so, this may be a way to trigger that bug, but not be a bug itself.

#2 Updated by Eric Allman almost 4 years ago

  • Related to Bug #9: Router terminating connections abruptly added

#3 Updated by Eric Allman almost 4 years ago

The Zeroconf part of this is resolved (see issue #30). The signature write failure part is still open.

#4 Updated by Eric Allman almost 4 years ago

  • Related to Bug #30: Zeroconf lookup hangs on reconnect attempt added

#5 Updated by Nitesh Mor almost 4 years ago

Here's how to reproduce this:

  1. Start gdplogd.
  2. Use the visualization tool at http://gdp.cs.berkeley.edu:8888/ and go to Chair 1,
  3. Hit 'Plot'.
  4. Look at the system log of gdplogd. It should be something like:
get_open_handle: opening OSbcXbklH_LEH2qqdo_PiiohaEAKJlf6fx6MQBuO934
_gdp_pdu_out: signature write failure: Success
_gdp_event_cb: got EOF, 0 bytes left
Trying Zeroconf:

The log OSbcXbklH_LEH2qqdo_PiiohaEAKJlf6fx6MQBuO934 maps to edu.berkeley.eecs.swarmlab.device.c098e530002b, which exists but is empty.

#6 Updated by Eric Allman almost 4 years ago

  • Duplicated by Bug #32: Router not allowing gdplogd to connect added

#7 Updated by Eric Allman almost 4 years ago

  • Duplicated by deleted (Bug #32: Router not allowing gdplogd to connect)

#8 Updated by Nitesh Mor almost 4 years ago

  • Due date set to 08/15/2016
  • Status changed from New to In Progress

#9 Updated by Nitesh Mor almost 4 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF