Project

General

Profile

Bug #30

Zeroconf lookup hangs on reconnect attempt

Added by Eric Allman almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
libgdp
Start date:
08/02/2016
Due date:
% Done:

0%


Description

If a router goes down, the client (in this case including gdplogd) will attempt to re-connect. If it tries Zeroconf, and if the Zeroconf daemon is running, the second attempt hangs.

To reproduce:
1. Make sure avahi-daemon is running.
2. Start gdp_router.
3. Start gdplogd. I suggest using -D*=34 to get Zeroconf debugging output.
4. Kill gdp_router.

If you compare the Zeroconf debugging output from when you first started gdplogd versus when it tried to reconnect you'll see that the startup function (creatively named "start") is never called.


Related issues

Related to GDP - Bug #28: gdplogd losing connection to the router. signature write failure: Success Closed 07/28/2016 08/15/2016

History

#1 Updated by Eric Allman almost 3 years ago

  • Status changed from New to Resolved

Fixed. The problem was that the Zeroconf code was leaving global state around that confused later calls.

#2 Updated by Eric Allman almost 3 years ago

  • Related to Bug #28: gdplogd losing connection to the router. signature write failure: Success added

#3 Updated by Nitesh Mor almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF