Project

General

Profile

Bug #51

Corrupt time-index causes gdplogd to crash (assertion failure)

Added by Nitesh Mor about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
gdplogd
Start date:
08/24/2016
Due date:
% Done:

0%


Description

How to reproduce:

./gdp-reader -D *=10 -t -f 1551471 -n 1 -G gdp-01.eecs.berkeley.edu edu.berkeley.eecs.swarmlab.device.c098e5300003

Here's the information from the log on the server side:

2016-08-25 00:21:45.184128 get_open_handle: opening 4RPmOEEboug46rExalX8F9HdGKB9aH5kAzhTfXNW4DY
2016-08-25 00:21:45.185932 Assertion failed at logd_disklog.c:1581: failure:
2016-08-25 00:21:45.185972      disk_read_by_recno: recno mismatch: wanted 1551471, got 1551127
2016-08-25 00:21:45.185992 2016-08-24 17:21:45.185933 -0700 gdplogd: Aborting on signal 6: ABORT: generic abort [EPLIB:generic:0]

History

#1 Updated by Nitesh Mor about 4 years ago

  • Status changed from New to Closed

My bad, looks like commit:b817c441 fixes this already. Should've checked out the latest version

Also available in: Atom PDF