Project

General

Profile

Bug #59

Segmentation fault in gdp-reader on subscriptions

Added by Nitesh Mor almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
libgdp
Start date:
09/27/2016
Due date:
% Done:

0%


Description

On a log with no new appends, leaving a subscription running causes segmentation fault after a while. See a detailed log attached, but here are the relevant parts (with a -D *=50):

<<< _gdp_invoke(0xeb82e0 rid=2) CMD_SUBSCRIBE: ERROR: Connection timed out [EPLIB:errno:110]
  req@0xeb82e0:
    nextrec=0, numrecs=0, chan=0xeb7d20
    postproc=(nil), sub_cb=(nil), udata=(nil)
    state=ACTIVE, stat=OK [67896520 = 0x40c04c8]
    act_ts=2016-09-28T05:06:09.349659000Z
    flags=0x1d5<ASYNCIO,CLT_SUBSCR,PERSIST,ALLOC_RID,ON_GCL_LIST,ON_CHAN_LIST>
    GCL@0xeb85f0: hgbwu1gFUggW4KJagnQujxReLFZgfg8Fzc-eq6QZ1wE
    iomode = 1, refcnt = 5, reqs = 0xeb82e0, nrecs = 23
    flags = 0xa<INCACHE,INUSE>
    PDU@0x7f0050000db0:
    v=3, ttl=15, rsvd1=0, cmd=128=ACK_SUCCESS
    dst=THCSJeJG0s-QjdSTmUQuXRlhYW-vj3-f6r0uO3-sqKg
    src=hgbwu1gFUggW4KJagnQujxReLFZgfg8Fzc-eq6QZ1wE
    rid=2, olen=0, chan=0xeb7d20, seqno=0
    flags=0
    datum=(nil)
    total header=80

subscr_resub(hgbwu1gFUggW4KJagnQujxReLFZgfg8Fzc-eq6QZ1wE) ->
    ERROR: Connection timed out [EPLIB:errno:110]
gdp_datum_free((nil))
Unknown event type 5
Segmentation fault

On commit:8b8120

subscr.log Magnifier (37.2 KB) Nitesh Mor, 09/27/2016 10:09 PM

History

#1 Updated by Eric Allman almost 4 years ago

  • Status changed from New to Feedback
  • Priority changed from Normal to High

This appeared in my recent commit for issue #54. It should be fixed in commit:60e57723. Please double check that it has been fixed.

#2 Updated by Nitesh Mor almost 4 years ago

  • Status changed from Feedback to Closed

Seems to be fixed. I can't reproduce it anymore. Thanks

Also available in: Atom PDF