Project

General

Profile

Bug #78

A routing failure causes gdplogd to become non-responsive.

Added by Nitesh Mor almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
gdplogd
Start date:
10/17/2016
Due date:
% Done:

0%


Description

If a client with subscriptions goes away, gdplogd gets a NAK_R_NOROUTE when attempting to deliver the data. However, any NAK_R_NOROUTE (or I believe any ACK/NAK) causes the log-server to go in an undefined state.

Here's what it looks like in the log files:

2016-10-17 20:23:31.583741 *** Processing ack/nak 240=NAK_R_NOROUTE from socket 7
2016-10-17 20:23:31.583744 gdp_gcl_cache_get: XB1KZ-OSJeA8d4hzyZ0WyzSMPyXd1A--sdUPvC500II => NULL
2016-10-17 20:23:31.583746 gdp_pdu_proc_resp(0x7f313c000d80 NAK_R_NOROUTE) gcl (nil)
2016-10-17 20:23:31.583748 find_req_in_channel_list: searching

Related issues

Duplicates GDP - Bug #77: GDP Log Server Crashes when we end subscription Closed 10/16/2016

History

#1 Updated by Nitesh Mor almost 4 years ago

  • Duplicates Bug #77: GDP Log Server Crashes when we end subscription added

#2 Updated by Nitesh Mor almost 4 years ago

  • Status changed from New to In Progress

#3 Updated by Nitesh Mor almost 4 years ago

  • Priority changed from Normal to Urgent

#4 Updated by Nitesh Mor almost 4 years ago

Just a status update/record-keeping: As far as I can tell, this bug was introduced by commit:b39dd5f8.

#5 Updated by Nitesh Mor almost 4 years ago

  • Status changed from In Progress to Resolved

Fixed by Eric in commit:8a3b26f9. I can't reproduce it anymore.

I will keep watching it for a few days, if there are any further complications.

#6 Updated by Nitesh Mor almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF