Some documentation of gdp_name.c changes for database connection pools.
Relocate etc/ep_adm_params into etc/gdp/params so that the etc/gdp
subtree can be mounted easily into a docker container.
Change (and document) defaults for event timeouts to be more realistic.
Rationalize lots of documentation. Fix inconsistencies in some
parameter names (e.g., swarm.gdp.gdp-create.server,
swarm.gdp.creation-service.name, and swarm.gdp.create.service). Some
minor code changes for consistency changes, but mostly docs.
Add -p and -P flags to gdp-name-add (for database passwords),
rationalize some of the administrative parameter names, and update
Cleanup on human-oriented name handling during creation, including
documentation. Big changes: don't allow a "human name" that looks like
a base-64-encoded name; use GDP_NAME_ROOT when creating a new log using
gdp-create; treat a zero-length GDP_NAME_ROOT as though the variable...
Make all references to the Human-Oriented Name to GDPname Directory
Service Database use "hongdb" in the name rather than "namedb" for
Update documentation for swarm.gdp.crypto.key.path.
Split variable swarm.gdplogd.log.dir into swarm.gdp.data.dir (the root
of persistent data) and swarm.gdplogd.log.dir (relative to the other).
This is primarily to make container management easier.
Also, when reading parameter files, allow auto-qualification with the...
Mega-change: new object creation API with updated metadata; internal
name is hash of metadata, not hash of human name; query and maintain
human-oriented name to GDPname directory (HONGD).
First cut at external => internal name mapping using MySQL. It is
currently not an error if the mapping doesn't exist --- it just falls
back to the old SHA256 behavior --- and there is no automated addition
of the mapping to the database when you create a log. To make this work...
Add new administrative parameters to ignore SIGPIPE in gdplogd
(swarm.gdplogd.ignore.sigpipe) and applications in general
(swarm.gdp.ignore.sigpipe). This allows the library to reconnect to the
router if the connection gets interrupted during a write. However,...
Minor formating changes in gdp.7.
Add runtime parameters "swarm.gdp.command.runinthread" and
"swarm.gdp.response.runinthread" to control whether commands and
responses (respectively) run in separate threads from the pool. Default
to true and false respectively. Running responses in threads is...
Convert units for libep.assert.resetinterval to milliseconds; change the
defaults for that and libep.assert.maxfailures to 2000 (2sec) and 100
Clean up parameters for subscription refreshing/expiry to make it harder
to make stupid mistakes.
Update man pages to match previous commit.
Move some of the assertion recover cleverness from gdplogd into libep so
it is more generally available. Also updates the documentation to make
it clearer (I hope).
Add swarm.gdp.cache.reclaim.maxgcls parameter; this is to detect loops
in the GCL usage list.
Rationalize swarm.gdp.subscr.deadintvl and swarm.gdplogd.subscr.timeout.
Rename deadintvl to be timeout and swarm.gdp.subscr.pokeintvl to
swarm.gdp.subscr.refresh for consistency.
Add swarm.gdp.debug.assert.allabort to make all assertions abort
Add runtime flag to turn off Nagle algorithm (TCP_NODELAY).
Take number of available file descriptors into account when reclaiming
the GCL cache.
Update documentation to include Zeroconf administrative parameters.
Improve documentation of GDP administrative parameters.
Add more documentation; a few code changes to make parameter naming more
consistent (as became obvious writing the documentation).