Project

General

Profile

Statistics
| Branch: | Tag: | Revision:

gdp / lang / js / package.json @ master

History | View | Annotate | Download (1.48 KB)

# Date Author Comment
180c3266 09/06/2017 09:24 AM Christopher Brooks

Updated version number so that npm module works under RHEL.

79d3ea46 09/05/2017 01:25 PM Christopher Brooks

Updated @terraswarm/gdp node module to gdp version

7244e92d 07/28/2017 05:52 AM Christopher Brooks

Updated JavaScript and Java to 0.8.0.

6ce4a2a2 06/04/2017 09:40 AM Christopher Brooks

Bumped version number so that the npm module is based on RHEL instead of Ubuntu.

ff4e229b 05/31/2017 03:49 PM Christopher Brooks

ffi dep changed from ~2.0.0 to >2.0.0. Updated version, added repository.

62050fe0 04/26/2017 10:19 AM Christopher Brooks

Updated @terraswarm/gdp node module to gdp version 5f47f25d76b9adcde9d55b763d642ef1ceeed782

e29e8cce 04/19/2017 11:19 AM Christopher Brooks

Published 0.7.39 based on 0de5c9d3404f5aacdab3c4b9c196c30fd943a041++.

398baedf 04/11/2017 02:36 PM Christopher Brooks

Updated version to 0.7.35 to match dad48a4..c2f7e02.

b3e16f5d 02/08/2017 04:32 PM Christopher Brooks

Updated npm version to 0.7.34. Npm requires that the version number be updated each time the package is published.

2bf259bb 10/23/2016 02:35 PM Christopher Brooks

Conditionalize debugging.

0020f274 10/23/2016 02:10 PM Christopher Brooks

Properly copy around rhel shared library for node interface.

6b3a6b97 10/23/2016 01:06 PM Christopher Brooks

Bumped up version so that we can publish to npm.

9d756c4c 10/23/2016 11:21 AM Christopher Brooks

Incremented npm package version.

9db39e8c 10/22/2016 10:02 PM Christopher Brooks

Fixed up how we copy around platform-dependent shared libraries.

45e498cc 10/22/2016 09:14 PM Christopher Brooks

When appending data to a log, it is not necessary to append a null. Updated version. Added info about installation and development.

adf862b5 10/22/2016 08:53 AM Christopher Brooks

Updated to npm library to 0.7.16 because to upload a new version of @terraswarm/gdp to npm, we need to increment the version number. Unfortunately, this means that the version number of the npm module does not match the version number of the underlying gdp library.

8b8120ec 09/27/2016 09:27 PM Christopher Brooks

Use 'make all', not 'make all_noavahi'. Fixed typo in testing. Updated version number and published.

e45215fd 09/09/2016 10:00 PM Christopher Brooks

Fixed problem in detecting RHEL. Updated docs to mention npm-autoinit.

60c6eafe 09/09/2016 09:42 PM Christopher Brooks

Updating user.name and user.email.

0153b908 09/09/2016 06:21 PM Christopher Brooks

Added mocha test for the GDP JavaScript interface. Updated Makefile to copy adm/gdp-setup.sh and common-support.sh so that they are part of the npm package that is downloaded.

e05a3b27 08/23/2016 04:46 PM Christopher Brooks

To get JavaScript access to the ep* symbols, call ffi.Library() on libgdp instead of libep because libgdp is statically linked with libgdp and has the ep* symbols in it. See https://www.terraswarm.org/accessors/wiki/Main/GDPJSNotes#DebugNotWorking.

a0722c7e 08/23/2016 01:48 PM Christopher Brooks

Start on attempting to use callbacks for subscription.

6bd6d1e9 08/18/2016 06:35 PM Christopher Brooks

Incremented gdpjs patch number for npm publish

674aefda 08/18/2016 06:08 PM Christopher Brooks

Increment gdpjs version number so that npm publish works.

17e3bb2b 08/18/2016 05:50 PM Christopher Brooks

Marginally working GDP/JavaScript subscription.

c5113e6f 08/12/2016 04:29 PM Christopher Brooks

Cleaned up formatting.

cfbf355b 08/12/2016 04:06 PM Christopher Brooks

Update version to 0.7.1 of the JS/GDP interface so that we can publish the new version with README.md. The version number of the GDP itself remains unchanged.

69d8c28f 08/12/2016 02:46 PM Christopher Brooks

GCL Create, Append and Read are working on the Node Accessor Host. Updated version number.

ec4bc124 08/04/2016 09:02 AM Christopher Brooks

Updated JavaScript interface to 0.6-1.

e12c315d 07/31/2016 08:47 AM Christopher Brooks

Bumped patch number up to 0.5.1. The patch number needs to be updated each time the Node npm module is updated. Also, state that linux is supported.

e670a490 07/20/2016 08:37 AM Christopher Brooks

Make the devDependencies be dependencies.

fd8fbe2d 07/20/2016 06:05 AM Christopher Brooks

Use version 2.0.0 of ffi.

731006fe 07/20/2016 05:28 AM Christopher Brooks

Set up to use @terraswarm/gdp npm module. Various cleanups to gdpjs.js

38f5ae1f 07/17/2016 02:35 PM Christopher Brooks

Part way to an accessor interface for the gdp.