Add a "mkfs" subcommand to gdpfs_cmd to create a new filesystem.
Unfortunately this requires extensive changes to the code (perhaps it
should have been standalone rather than a subcommand), and I'm not sure
that the "ls" subcommand is behaving as expected yet.
Try to fix problems with large files in gdpfs. Unclear if this will fix
Signature support [WIP]
Basic signature inclusion/verification.
Check whether a GDP path is valid or not
better comand line options for gdpfs_util
Moved Stat functionality to GDPDir
Moved GetMatchingPath from gdpfs_tf.cc to gdpfs.cc
Moved implementation of GetChildren to GDPDir
rename GDPDir method names to match that of TF FS
Minor commenting improvement
minor rearrangement + return code impl for Appends
Cleanup for Set/GetCache
Stricter error checking for GDPfsInit, CreateLog
minor documentation update
use const std::string for GDPFileWO::Append
Use const std::string for AppendRecord (not a ptr)
Move ParseMsgFchunk outside as a general util func
Misc enhancements for GDPFile (filesize, etc)
minor rearranging + code cleanup
covert logname from char* to std::string
Prettify things: minor indentation/ordering changes
Reorder #includes; rename functions
Adhere to naming convention for data members
More refactoring, no code changes
Refactoring/code-cleanup. No logical changes.
Better support for RO files updated elsewhere.
Also changed the underlying storage for MemMap files from
a charbuf to a std::string.
Keeps tensorboard somewhat happy [i.e. loads data without restarts]
implement mtime; unify freshness check into a single 'sync' function
Moved timekeeping to gdpfs.h (+ updated things)
update record sizes
implement renaming files + bug fixes
Support for recursive creation of directories
Comments to better define semantics of path parsing
remove check_protocol. Use common split_path implementation
TODO: define semantics for path operations properly
add split_path + revert parse_path to old behavior
check that x/y/ exists before creating x/y/z
add get_entry_type; get_logname => get_entry_logname
Simplify directory ops + remove some duplication
separate protocol checking from parse_path
change the semantics of parse_path.
More code reorganization
=> move one-liner simple functions to .h [inline]
code reorganization; no semantic changes
New class GDPFile. Pass RO/RA flag to GDPDir
Added path validity check; ParsePath => parse_path
added support for a global I/O mode
param reading from conf+ get logprefix from conf