Cleanup refs to ent_info in agent
Now, the agent has three local variables: "name", "md", "priv_key"
Makes it streamlined to access these essential properties of an
Adding missing tests
Dump the full list of times
Renaming switch => router.
TODO: DHTnode should be renamed to blackbox. Coming soon.
Use SwitchDesc for address+name in a single DS
support for individual switches with their own address
Endpoint => Entity, ep=>ent.
Better reflect that the same datastructure can be used for
endpoints, organizations, routers, routing domains, etc.
Update to function names as well
Pass address instead of ID file as cmdline
WIP: Support for routing domain as a parameter
rename function names *Endpoint=> *_endpoint
Removed trailing whitespaces.
Fixed tests to generate endpoints on demand
allow adverts to go through before pinging
Separated routing tests from log-operations
Basic testing for network using Ping